明凯博客

关注网站技术,一个特立独行的程序员

WordPress调用自带jquery的方法及区别

一、调用自带jquery方法

1
< ?php wp_enqueue_script("jquery"); ?>

但要注意的是: wp_enqueue_script(“jquery”); 务必加在 wp_head(); 的前面。
同时,需要注意的是wordpress自带的jquery和官方的jquery是有区别的,自带的jquery则需要这样使用:

1
2
3
jQuery(document).ready(function($) {
// "$"符号在这里才能被识别
});

WP 的 jQuery 和原版唯一的不同, 就是在最后一行加了 jQuery.noConflict();这个noConflict() 就是为了与其它的library 兼容性, 如:Prototype, MooTools, 或 YUI。
二、调用其他jquery方式
1.最直接的:

1
<script type=”text/javascript” src=<?php bloginfo(‘template_url’); ?>/js/jquery.js></script>

2.调用谷歌 Google 的 API库:

1
2
3
4
5
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.6.1/jquery.min.js"></script>
//最好再加上以下代码,一边在连接google的API库是失效时调用本地的jQuery文件:
<script>
!window.jQuery && document.write('</script><script src="jquery-1.6.1.min.js">< \/script>');
</script>

三、取消使用自带jquery
网上最多的方法是在/wp-includes/script-loader.php的119行,将

1
2
3
4
5
6
7
$scripts->add( 'jquery', '/wp-includes/js/jquery/jquery.js', false, '1.7.1' );
 
//修改为
 
if(is_admin()){
 $scripts->add( 'jquery', '/wp-includes/js/jquery/jquery.js', false, '1.7.1' );
}

这个方法不支持wp升级,因为升级后会将这个文件修改回来。另外jucelin想到的最简单的方法就是,将官方的jquery替换自带的jquery文件(这个方法会导致后台无法使用自带jQuery!)当然这也应该不支持wp的升级,升级后会被新的jquery覆盖掉。

, , ,

相关文章

发表评论

电子邮件地址不会被公开。 必填项已用*标注