明凯博客

关注网站技术,一个特立独行的程序员

WordPress3.8版本无法使用smtp发送邮件的解决方法

以前用wordpress3.8以前的版本发送邮件问题使用下面的方法可以解决:

发送邮件出现Could not connect to SMTP host的解决办法

可是wordpress现在都4.0版本了,上面的方法根本不够用,肯定解决不了办法。

而网上的方法都是全部抄来抄去根本没有效果。

在此明凯自己研究后发现了下面的问题及解决方法。

3.8版本使用的是fsockopen发送socket。以后的版本使用的是 stream_socket_client发送socket。
php.ini默认禁用了stream_socket_client这个函数。

3.8以前的版本:
smtp1

3.8以后的版本:
smtp2

大家可以看看phpinfo的信息:

smtp3

这个函数是禁用的。

大家可以修改php.ini:

smtp4

删除掉disable_functions里面的stream_socket_client就可以了。

smtp5

大家感受下。看下效果。

, , ,

相关文章

1 条评论 “WordPress3.8版本无法使用smtp发送邮件的解决方法

发表评论

电子邮件地址不会被公开。 必填项已用*标注